Read Error when exporting wavefunctions

Mirjam Van Vroonhoven mirjamv at
Wed Jan 24 10:52:08 GMT 2001

I try to export Oxygen MRCI wavefunctions with the EXPORT card. For some
states, it works fine, but for other states I get the following error message:

EXPORT record  6000.2 to   file
rdabsf: Error in reading from file T1200004124.TMP (unit 12),
  4096 words at word offset 38912
rdabsf: Error in reading from file T1200004124.TMP (unit 12),
  4096 words at word offset 38912

(where I added two newlines to increase readability, the numbers are variable,
but the message is the same all the time)

It works fine for (for example) the b Singlet Sigma_g^+ of O_2, but it crashes
for the ground state X Triplet Sigma_g^-.

I used the following molpro input:
------- For X Triplet Sigma gerade minus ------
  #!/bin/csh -f -e

  time nice +19 molpro << EOF
  ***, O2 CI crashing of export
  R = 2.2





The input for the b Singlet Sigma gerade plus state was exactly the same,
except for the WF card in the Hartree - Fock, which read "wf,16,1,0". This job
worked fine.

The error seems to be generated in the routine export
($molpro/src/util/export.f), during the call to the subroutine lesw
($molpro/src/util/sreibw.f) which reads the requested record from temporary
file number 2 (unit 12). The routine lesw calls the routine rdabsf which is a
lowlevel IO routine. This one generates the error.

Can someone tell me what is wrong here? It is not a problem of the disk being
full or something. I run molpro on a SUN Ultra-Enterprise machine, with
Solaris 2.7.

Mirjam van Vroonhoven
PhD student in Theoretical Chemistry.
E-mail:           mirjamv at
Phone:            +31-24-365 30 33
Visiting Address: Department of Theoretical Chemistry
                  Toernooiveld 1, Room number N2035
                  6525 ED  Nijmegen

More information about the Molpro-user mailing list