Molpro and the Intel-Linux Compiler

Thomas Weber thw at
Wed Nov 21 21:11:25 GMT 2001

Hallo !

I managed to compile and link molpro with the Intel compiler. But the result 
does not run correctly. The program starts, parses the input and hangs after 
the following lines in an endless loop:

 SETTING ROH            =         1.00000000  ANGSTROM
 SETTING THETA          =       104.00000000  DEGREE
 SETTING R              =         4.50000000  ANGSTROM

 Variable memory set to    1000000 words,  buffer space   158000 words

 Using spherical harmonics

Only Ctrl-C will stop it.

Because I have no knowledge about molpro internas, I have no idea how to 
address this problem.

How to compile with the Intel compiler:

1. Do a "configure" and configure for g77.
2. Change the FC to "ifc -w95"
    and the LINKFC to "ifc -w95 -Vaxlib -C90 "
   (this does not include any architecture optimization)
3. Doing a make results in to types of Errors:
a) Array boundary violation: eg: q(2) where q is declare with demension 1.
Simply use a variable: temp = 2; q(temp)
b) functions without a return value
change them to subroutine

There a about 10 files affected.

The most difficult thing was to link the licence object, because of 
unresolved references. The following call to a binutil fixed it:

objcopy --redefine-sym _IO_stderr_=_IO_stderr 
parse-i686-pc-linux-gnu-i4.o.orig parse-i686-pc-linux-gnu-i4.o

BTW: I also tried the p4-version of the atlas blas library, and I am not 
really happy with that solulotion. Escpecially the MRCI-program seems not to 
use blas-routines. There was no increasment of preformance compared to the 
build in blas routines. (pgf-compiler)

so long

P.S. I am a collegue of  Elmar :-)

More information about the Molpro-user mailing list