[molpro-user] Building molpro2002.6 parallel executable. Need help!

Vadim V. Kislov kvv_bne at mail.ru
Wed Nov 24 18:46:03 GMT 2004

Dear Molpro users,

I tried to build parallel molpro 2002.6 executable, but compilation was failed at linking.

My system: Dual Xeon workstation under redhat 8.0 (2.4.18-14bigmem), Intel fortran compiler 8.1, Global Arrays 3.3.1. I run configuration script like this: 

[root at chedaac molpro2002.6]# ./configure -mpp

Building program for processor type=p4
Program may not run on amd64/athlon/p3 systems
You can choose another processor type using the amd64|athlon|p3 options

Program will be built for parallel execution
Machine architecture is unix unix-i4 unix-linux
Additional compilation pre-processor flags: mpp eaf

File size greater than 2GB allowed

Using Intel Fortran compiler (ifc for ia32) version 8

searching for blas libraries...

plese select blas library from above list
(default ):


searching for lapack library...

plese select lapack library from above list
(default ):

Do wish to use tcgmsg, mpi, or myrinet? [tcgmsg]

Please give the name of the directory containing GA, MA libraries:
(default ):
If you want to use a special wrapper for parallel job startup
please specify. (default /tmp/g/tcgmsg/ipcv4.0/parallel):

Please enter your licence key
(default ):
Enter max number of atoms [ 200]:
Enter max number of valence orbitals [ 300]:
Enter max number of basis functions [2000]:

If you wish to use a system BLAS library, please give the maximum
level (0, 1, 2, 3) of BLAS to be supplied by the system
(default 0):

Installed binaries directory [/usr/local/bin]
Installed auxiliary directory [/usr/local/lib/molpro-mpp-Linux-i686-i4-2002.6]
parse-i686-pc-linux-gnu-i4.o.gz is your object.
CONFIG file created; please inspect and edit if necessary before proceeding

Then compilation was Ok, but linking was failed with error message:

linking /usr/local/molpro2002.6/bin/molprop_2002_6_i4_tcgmsg.exe
link failed
/opt/intel_fc_80/bin/ifc -pc 64 -auto -autodouble -Vaxlib -w -O3 -Wl,-rpath,/opz
ifc: warning: The Intel Fortran driver is now named ifort.  You can suppress th'
/tmp/g/lib/LINUX/libtcgmsg.a(pbeginf.o): In function `pbeginf_':
pbeginf.o(.text+0x8): undefined reference to `f__xargv'
pbeginf.o(.text+0xe): undefined reference to `f__xargc'
/tmp/g/lib/LINUX/libpario.a(eaf.o): In function `eaf_print_stats':
eaf.o(.text+0x256): undefined reference to `__fixunsdfdi'
make: *** [bin/molprop_2002_6_i4_tcgmsg.exe] Error 1

I expect that something may be wrong with my Global Arrays libraries, but they seem to be installed properly.   
If you have any suggestion in solving this problem, your help will be greatly appreciated.


Vadim V.Kislov
Postdoctoral Research Associate,
Department of Chemistry and Biochemistry,
Florida International University
11200 SW 8th Street, Miami, FL 33199
e-mail: kvv_bne at mail.ru
tel: 305-348-1945

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.molpro.net/pipermail/molpro-user/attachments/20041124/ecbfe055/attachment.html>

More information about the Molpro-user mailing list