[molpro-user] MOLPRO, MPIRUN & DPLACE

Joseph Lane jlane at alkali.otago.ac.nz
Tue May 17 11:53:24 BST 2005

I am having difficulties submitting jobs to specific chips within my SGI  
Altix 350. It seems that whenever I run molpro using mpirun and dplace, it  
automatically uses the default arguements and ignores my user specified  
dplace arguements. This is resulting in some chips running more than one  
job, while other chips remain idle.

 from a ps -ef, I run

jo       14687 25166  0 11:17 pts/2    00:00:00 mpirun -np 2  
/usr/bin/dplace -e -s1 -c6-7 /home/qchem/molpro2002/molprop_2002_6_i8_mpi

which results in

jo       14690 14687  0 11:17 pts/2    00:00:00  
jo       14691 14690  0 11:17 pts/2    00:00:00 mpirun -np 1  
/usr/bin/dplace -s1 /home/qchem/molpro2002.6/bin/molprop_2002_6_i8_mpi.exe

i.e it ignores the request for 2 chips, using CPU's 6 & 7, and runs on 1  
chip (CPU 4)

Can anyone please tell me the correct way to submit jobs using mpirun and  
dplace so that

Joseph Lane
Department of Chemistry
University of Otago
P.O. Box 56
Dunedin, New Zealand
ph +64 3 479 5214
email : jlane at alkali.otago.ac.nz

More information about the Molpro-user mailing list