[molpro-user] PGI's optimization tips for Opteron

Nick Wilson WilsonNT at Cardiff.ac.uk
Thu Nov 10 13:50:23 GMT 2005

Dear Scott,

The unresolved symbols are supplied by src/util/gmainv.o so I'm not sure 
why they're missing. Try deleteing this file and recompiling.

I have previously tried using the PGI -fastsse optimisation settings on 
a parallel build and ran into some problems with some of the testjobs 
(on a tcgmsg build). I think the aggressive optimisation flags make some 
assumptions about how the data is aligned which can cause problems with 
the parallel communication. I have tinkered with the flags for the 
global arrays build but I have not personally got it working correctly 
with tcgmsg with the -fastsse setting. It might work OK with mpi but I 
haven't tested that yet.

Best wishes,

Scott Yockel wrote:
> Molpro users,
> With the default optimization flags molpro2002.6-mpp will compile and 
> link correctly for my Opteron-myrinet cluster with PGI 5.2, MPICH 
> 1.2.5..10, GA-3-4b.  Also when I compile a serial version with the PGI 
> optimization tips 
> (http://www.pgroup.com/resources/molpro/molpro2002.6_pgi52_64.htm) as 
> they have in their CONFIG file, everything compiles and links correctly 
> and the code runs about 10-20% faster.
> Problem is when I try the PGI suggestions for the mpp compilation by 
> adding "-Mcache_align" to FC and F90, add "-fastsee" to LINKFC, and 
> change FOPT="-fastsee -Mnoflushz" molpro will no longer link correctly.  
> I've also tried adding to the optimization flags "-Mlarge_arrays 
> -mcmodel=medium" and get the same link error.  Below is the link error.  
> I would really appreciate the help to get this compiled with the 
> additional optimization flags since in makes a significant improvement 
> in the run times.
> Thanks
> ~Scott Yockel
> link failed
> /usr/local/pgi/linux86-64/5.2/bin/pgf90 -pc 64 -i8 -Mcache_align 
> -Mlarge_arrays -mcmodel=medium -fastsse -Mnoflushz -g77libs -o 
> /CHEM/molprop_smy_pgi/bin/molprop_2002_6_i8_amd64_myrinet.exe molver.o 
> molpro.o -L/CHEM/molprop_smy_pgi/lib -lmolpro 
> -L/usr/local/ga-3-4b/lib/LINUX64 -lglobal -ltcgmsg-mpi -lma -lpario 
> -larmci -L/usr/local/gm/lib -lgm -lpthread 
> -L/usr/local/mpich/1.2.5..10/gcc/x86_64/lib -lmpich -L/usr/local/gm/lib 
> -lgm -lgks0 -lacml -L/usr/local/ga-3-4b/lib/LINUX64 -lglobal 
> -ltcgmsg-mpi -lma -lpario -larmci -L/usr/local/gm/lib -lgm -lpthread 
> -L/usr/local/mpich/1.2.5..10/gcc/x86_64/lib -lmpich -L/usr/local/gm/lib 
> -lgm -lz
> /CHEM/molprop_smy_pgi/lib/libmolpro.a(util.o)(.text+0x3cfc): In function 
> `inicor_':
> : undefined reference to `fmain_'
> /CHEM/molprop_smy_pgi/lib/libmolpro.a(util.o)(.text+0x3ecc): In function 
> `inicor_':
> : undefined reference to `fmain_'
> /CHEM/molprop_smy_pgi/lib/libmolpro.a(util.o)(.text+0x3f96): In function 
> `inicor_':
> : undefined reference to `gmainv_'
> /CHEM/molprop_smy_pgi/lib/libmolpro.a(util.o)(.text+0x549d): In function 
> `endcor_':
> : undefined reference to `fmain_'
> make: *** [bin/molprop_2002_6_i8_amd64_myrinet.exe] Error 1

More information about the Molpro-user mailing list