[molpro-user] all 2008.1 builds crash at beginning with a RemoteCreate error

Andy May MayAJ1 at cardiff.ac.uk
Thu Mar 5 14:07:31 GMT 2009

After following this up it turns out this was due to HOST being
incorrectly determined in the bin/molpro shell script.

There are general problems with this since some shells set HOST as
`hostname -f`. The was worked around in a recent patch but has now
caused problems when the hostname written in /etc/hosts is a fully
qualified address.

I will try to make a patch that takes care of this, but if you
experience such problems it may be easy to fix by experimenting with the
'HOST' variable at the top of the bin/molpro shell script.

Best wishes,


Benj FitzPatrick wrote:
> Hello,
> I was able to compile 2008.1 a few months ago, but I've done something since
> then that kills every build.  I'm using opteron 285s with 64bit libraries
> (either goto blas 1.26 + lapack 3.1.1 or mkl and pathscale 3.2 or
> ifort 10.1.018.  I've tried global arrays 4.0.2, 4.0.8, and 4.1.1.  No errors
> came up when building any of the libs and the GA tests completed successfully.
> The error I get any time I run molpro (the example below was when I ran make
> tuning) kills the job after a few seconds.
> ...
> make[1]: Leaving directory `/ab/molpro-builds/21/lib'
> Optimizing tuning parameters...
> tmp = /home/benjfitz/pdir//ab/molpro-builds/21/bin/molpro.exe.p
>  Creating: host=dog, user=benjfitz,
>            file=/ab/molpro-builds/21/bin/molpro.exe, port=58683
>   1: RemoteCreate: in child after execv -1 (0xffffffffffffffff).
>   1: RemoteCreate: in child after execv -1 (0xffffffffffffffff).
> system error message: No such file or directory
>   1: interrupt(1)
> Tuning finished
> ---------------
> My configure line is,
> ./configure -i8 -x86_64 -ifort -mpp -mppbase /ab/ga/ga4.0.2-large-i8_ifc_mkl_4/
> -blas3 -lapack
> and my GA make line is,
> gmake TARGET=LINUX64 FC=ifort BLAS_I8=yes NATIVE_BLAS=no
> BLAS_LIB=-L/opt/intel/mkl/ -lmkl_intel_ilp64
> -lmkl_sequential -lmkl_core LARGE_FILES=yes>./make.log
> I've tried 3 different computers with 3 different versions of glibc 2.4, 2.8,
> 2.9 and the problem occurs on all of them.  I also tried building a version of
> 2006.1 that I knew worked, and it still does.  The last test I did was to
> install ifort and icc from new tar.gz's, and GA from the original tar.gz, and a
> newly downloaded molpro, but I still got the same problem.  Have I done
> something horrible to my CONFIG (I have attached my CONFIG) or to GA?
> Thanks,
> Benj FitzPatrick
> University of Chicago
> ------------------------------------------------------------------------
> _______________________________________________
> Molpro-user mailing list
> Molpro-user at molpro.net
> http://www.molpro.net/mailman/listinfo/molpro-user

More information about the Molpro-user mailing list