[molpro-user] [SOLVED] Molpro execution problem in Ubuntu 10.04

Sidney Santana santanasidney at yahoo.com.br
Thu Feb 10 21:52:43 GMT 2011

Dear Molpro User,

I am very grateful for the answers

that has been sending to me. 

I think the Molpro 2009 has been running well

until the Ubuntu 9.10.

So, I solved my Molpro problem when I upgrade it to

the lastest Molpro 2010 binary version.

Now it is running well in Ubuntu 10.04 64 bits.

Thanks you so much to everyone.

Best Regards,

Sidney R. Santana

The question can be read bellow:
Dear Molpro Users,

Please could anyone help me?

I am trying to execute the Molpro 2009 in a computer with

Ubuntu 10.04 64 bits (Kernel Version: 2.6.32-28 SMP, and

libc6 Version: 2.11.1-0ubuntu7.8).

But the program have been stopped

and typed the following error:

/opt/molpro/bin/molprop_2009_1_Linux_x86_64_i8.exe, len=50
cf3cl_8.inp, len=11
-master, len=7
ubuntu, len=6
39720, len=5
1, len=1
1, len=1
0, len=1
0, len=1
molprop_2009_1_Linux_x86_64_i8.exe: relocation error: /lib/libnss_files.so.2:
symbol __r awmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with
link time reference
tmp = /home/sidney/pdir//opt/molpro/bin/molprop_2009_1_Linux_x86_64_i8.exe.p
Creating: host=ubuntu, user=elizete,
file=/opt/molpro/bin/molprop_2009_1_Linux_x86_64_i8.exe, port=39720
1: interrupt(1)

Is this a Ubuntu version problem ?

Please could anyone tell me what is wrong and how can I fix that ?

Thanks for any help.

Best Regards,

Sidney R. Santana

The answers can be read bellow:

"Pietro Ottati pietro.ottati:-:gmail.com" <owner-chemistry_at_ccl.net>

"Santana, Sidney Ramos -id#4k3-" <santanasidney_at_yahoo.com.br>

I'm not an expert but do you set export LD_LIBRARY_PATH in your /etc/profile to 
define where is the library?

check MANUAL or INSTALL or REAME file of molpro...

I don't use it but it's possible that the solution...

"Kirk Peterson kipeters_._wsu.edu" <owner-chemistry_at_ccl.net>

"Santana, Sidney Ramos -id#4k3-" <santanasidney_at_yahoo.com.br>

Sent to CCL by: Kirk Peterson [kipeters .. wsu.edu]
Dear Sidney,

looks like an installation problem.  Do the test jobs work?  Which compiler are you using?

I would strongly recommend to post this to the Molpro users list (molpro-user at molpro.net). You'll
certainly get this worked out there.



"James Womack james.c.womack_._gmail.com" <owner-chemistry_at_ccl.net>

"Santana, Sidney Ramos -id#4k3-" <santanasidney_at_yahoo.com.br>

Sent to CCL by: James Womack [james.c.womack||gmail.com]
I can't offer any suggestions on how to fix the problem but I can tell
you that it's not a problem with Ubuntu generally. I'm running version
2010.1 (compiled from source) without problem on Ubuntu 10.04 32 bit. As
someone else said, it's worth going to the Molpro developers/mailing
list directly with this problem.

Hope you fix it soon,

"Andy May" <MayAJ1_at_cardiff.ac.uk>

"Sidney Santana" <santanasidney_at_yahoo.com.br>


Can you first try with the latest Molpro binaries (2010)? These are
built on a more recent OS and with the latest version of the compilers.

Best wishes,


"Thomas Ritschel" <ritschel_at_uni-potsdam.de>

molpro-user_at_molpro.net, santanasidney_at_yahoo.com.br, MayAJ1_at_cardiff.ac.uk
Dear Sidney and Andy,

in the latest Ubuntus (10.04 and 10.10) the glibc library was replaced by the
so called "embedded glibc" (eglibc).  It seems that this is not 100%
compatible to the standard glibc, at least if the binaries are generated on a
system which uses the standard glibc (leading to "undefined symbol" errors as
in your output).

More information about the Molpro-user mailing list