[molpro-user] Compiling Molpro with OpenMPI

Lasse Nielsen obessal at hotmail.com
Sun Dec 16 11:35:12 GMT 2012

I have tried to compile Molpro 2012.1 using Intels composer_xe_2013.1.117 (cc, fortran and mkl-library) and OpenMPI, both versions 1.6.2 and 1.4.3. However, every time I run the testjobs I get the same error message, see below.Both Molpro and OpenMPI was compiled on the frontend.       
I configured Molpro this way:./configure -icc -i8 -mpp -openmpi -mppbase /software/kemi/openmpi-1.4.3/include/ -prefix /kemi/obessal/MOLPRO -batchand then used Gnu Make 3.81 then make test
How can I solve this problem??

Running job aims.testCMA: no RDMA devices found
 GLOBAL ERROR fehler on processor   0    0: fehler 0 (0).    0: In mpi_utils.c [MPIGA_Error]: now exiting...--------------------------------------------------------------------------[[44089,1],0]: A high-performance Open MPI point-to-point messaging modulewas unable to find any relevant network interfaces:
Module: OpenFabrics (openib)  Host: fend03.dcsc.ku.dk
Another transport will be used instead, although this may result inlower performance.--------------------------------------------------------------------------Received signal 11 Segmentation violation    0: fehler 0 (0).--------------------------------------------------------------------------MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLDwith errorcode 0.
NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.You may or may not see output from other processes, depending onexactly when Open MPI kills them.----------------------------------------------------------------------------------------------------------------------------------------------------mpirun has exited due to process rank 0 with PID 11981 onnode fend03.dcsc.ku.dk exiting without calling "finalize". This mayhave caused other processes in the application to beterminated by signals sent by mpirun (as reported here).--------------------------------------------------------------------------**** PROBLEMS WITH JOB aims.testaims.test: ERRORS DETECTED: non-zero return code ... inspect output**** For further information, look in the output file**** /users/kemi/obessal/MOLPRO/Molpro/testjobs/aims.errout

Bonus question:Also, is it important to compile Molpro and OpenMPI with the same compiler?

Best Regards- Lasse
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.molpro.net/pipermail/molpro-user/attachments/20121216/84ef1599/attachment.html>

More information about the Molpro-user mailing list