[molpro-user] 2012.1 build with latest ifort

Kirk Peterson kipeters at wsu.edu
Sat Nov 10 21:25:12 GMT 2012

As an update to this, the problem with multi was easy to fix, just compile muaug.F with -O2.  The real problem is in the MRCI where it hangs for a long time and eventually I get a bunch of lines like:

 Number of p-space configurations:   1
  NON ZERO P-SP. GR.                     4  1.077040023123477E-003
   1.37714225160409       -25.2064501018170      -5.459178924531589E-002
  NON ZERO P-SP. GR.                     4  6.186392658566131E-003
  0.624789661427233       -29.6917480361564      -2.083418153809529E-002
  NON ZERO P-SP. GR.                     4  6.939620540519886E-003
   1.18397024064320       -39.0969508512373      -3.010543263543086E-002
  NON ZERO P-SP. GR.                     4  6.674144365430790E-003
   1.53773711679753       -59.8632618117633      -2.557600314607719E-002
  NON ZERO P-SP. GR.                     4  7.027066282512706E-003
   2.43885843805420       -104.128402980249      -2.335415988501181E-002
  NON ZERO P-SP. GR.                     4  3.631445207469497E-003
   5.56363239276109       -440.472955145745      -1.262279756929438E-002
  NON ZERO P-SP. GR.                     4  1.489914741162224E-003
   12.7352403036245       -2004.81756495344      -6.351575630363697E-003
  NON ZERO P-SP. GR.                     4  5.507653598897377E-004
   32.3847976001225       -13037.8013700382      -2.483873309282336E-003
  NON ZERO P-SP. GR.                     4  1.213631637853041E-004
   84.7182220590193       -90053.2547920299      -9.407555661536559E-004

everything else in h2o_vdz.test runs fine up until then.  The odd thing is this only happens in parallel (same build, just more than 1 core requested) and only on my new Intel Sandy Bridge processors (works fine on slightly older Nehalem procs).  I've tried ifort v13.0.1 and also ifort v12.1.6  with the same result.  This parallel build uses auto-ga-mpich2 .

a older build with ifort v11.1 works fine, but unfortunately I can't use this much since my Centos 6.0 upgrade has broken this compiler.

any hints or suggestions?


PS - in case it's not clear, this is a linux build.

>> Hi,
>> has anyone successfully built molpro2012.1 with the latest ifort, i.e., v13.0.1 ?  It seems to compile and link fine, but when running h2o_vdz.test it dies in multi with a segmentation fault:
>> GLOBAL ERROR fehler on processor   0                                         
>> I've built a mpp version (ga-mpich2) linked to the mkl library using gcc and g++ with everything else at their default settings.
>> best,
>> -Kirk
>> _______________________________________________
>> Molpro-user mailing list
>> Molpro-user at molpro.net
>> http://www.molpro.net/mailman/listinfo/molpro-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.molpro.net/pipermail/molpro-user/attachments/20121110/4895eeae/attachment.html>

More information about the Molpro-user mailing list