[molpro-user] ./configure -Block failed in 2012.1.2

Kenny W minjiwu at outlook.com
Sat Sep 28 10:52:31 BST 2013

Dear Roberto,
Thank you for your reply. Last night after I also got a failure with ORCA 3.0.0 in the same machine, I started to suspect that the Molpro configure -Block problem might have been resulted from the very old version of Linux (Debian 4.0 with glibc 2.3.6), so I tried to configure and compile the Molpro-Block in another more updated workstation (Debian 6.0.0 with eglibc 2.11.3-4 ). 
Now in the new host, the previous configure problem went away and the compilation went smoothly, the only problem occured at the linking stage with a complaint of undefined reference to `__builtin_fpclassify'.

make[4]: Entering directory `/tmp/molpro.2012.1.2/Molpro/src'link date: 27 Sep 2013 22:23:16 ; version: 2012.1SHA1 : 8344efe475b03c132f2fec100f1f46232803064fmake[4]: Leaving directory `/tmp/molpro.2012.1.2/Molpro/src'compiling molver.F90make[3]: Leaving directory `/tmp/molpro.2012.1.2/Molpro/src'linking ../bin/molpro.exefailed/tmp/molpro.2012.1.2/Molpro/src/Block-0.9.6/libqcdmrg.a(slater.o): In function `SpinAdapted::Slater::hash_value() const':slater.C:(.text+0x2605): undefined reference to `__builtin_fpclassify'make[2]: [../bin/molpro.exe] Error 1 (ignored)failure/tmp/molpro.2012.1.2/Molpro/src/Block-0.9.6/libqcdmrg.a(slater.o): In function `SpinAdapted::Slater::hash_value() const':slater.C:(.text+0x2605): undefined reference to `__builtin_fpclassify'make[2]: *** [../bin/molpro.exe] Error 1make[2]: Leaving directory `/tmp/molpro.2012.1.2/Molpro/src'make[1]: *** [default] Error 2make[1]: Leaving directory `/tmp/molpro.2012.1.2/Molpro/src'make: *** [src] Error 2
I also tried to replace Block directory with v0.9.7 but got the same error at the linking stage. The CONFIG file is attached. Could you please suggest for possible solution to this undefined reference? Thank you.


From: ro3 at princeton.edu
Date: Fri, 27 Sep 2013 17:23:00 -0400
Subject: Re: [molpro-user] ./configure -Block failed in 2012.1.2
To: minjiwu at outlook.com
CC: molpro-user at molpro.net

Hi Kenny,Did you compile configure from a clean version of molpro, or was molpro already built before and you are reconfiguring? Also, if you are going to run BLOCK, I recommend you run the code in parallel (i.e, including openmpi).

Best regards,
Roberto--Roberto Olivares-Amaya, Ph.D.Postdoctoral Researcher | Chan Group
Dept. of Chemistry | Princeton University

On Fri, Sep 27, 2013 at 8:59 AM, Kenny W <minjiwu at outlook.com> wrote:

Dear Molpro Experts,


I tried to configure and compile MOLPRO 2012.1.2 source code with the DMRG Block code. I used intel compiler 2011_sp1.10.319 (Version Build 20120410) and issued:

./configure -openmp -ifort -icc -blas -i8 -Block


The prompt returned:

machine type recognized as x86_64 (Generic 64-bit)

kernel recognized as Linux

user request compiler ifort

Intel Fortran Compiler, Version 12.1.4


user request compiler icc

Intel C compiler, Version 12.1.4


BLASLIB=-L/opt/intel/composer_xe_2011_sp1.10.319/mkl/lib/intel64 -lmkl_intel_ilp64 -lmkl_intel_thread -lmkl_core



The Block-0.9.6 was downloaded successfully and compiled automatically with:

make library MOLPRO=yes BOOSTINCLUDE=/temp/molpro2012.1.2.block/Molpro/src/boost-install/include OPENMP=yes USE_MPI=no CXX='/opt/intel/composer_xe_2011_sp1.10.319/bin/intel64/icpc'

but finally the configure script returned error messages as:

unable to link with parse object using:

/opt/intel/composer_xe_2011_sp1.10.319/bin/intel64/ifort  -i8 -r8 -pc64 -auto -vec-report0 -warn nousage -cxxlib  -openmp -O0  -L/temp/molpro2012.1.2.block/Molpro/src/Block-0.9.6 -lqcdmrg -L/temp/molpro2012.1.2.block/Molpro/src/Block-0.9.6/newmat10
 -lnewmat -lpthread /temp/molpro2012.1.2.block/Molpro/src/boost-install/lib/libboost_system.a /temp/molpro2012.1.2.block/Molpro/src/boost-install/lib/libboost_thread.a /temp/molpro2012.1.2.block/Molpro/src/boost-install/lib/libboost_filesystem.a /temp/molpro2012.1.2.block/Molpro/src/boost-install/lib/libboost_serialization.a


Please check the compiler is working, flags are correct and all libraries are present


failed to determine PARSE


Result so far of configure written to CONFIG.errout

However as I checked the libraries, all of the above-mentioned lib*.a were present:

-rw-r--r-- 1 root root 45223678 2013-09-27 18:49 /temp/molpro2012.1.2.block/Molpro/src/Block-0.9.6/libqcdmrg.a

-rw-r--r-- 1 root root 780596 2013-09-27 18:49 /temp/molpro2012.1.2.block/Molpro/src/Block-0.9.6/newmat10/libnewmat.a

-rw-r--r-- 1 root root  380756 2013-09-27 18:41 /temp/molpro2012.1.2.block/Molpro/src/boost-install/lib/libboost_filesystem.a

-rw-r--r-- 1 root root 2083932 2013-09-27 18:42 /temp/molpro2012.1.2.block/Molpro/src/boost-install/lib/libboost_serialization.a

-rw-r--r-- 1 root root   46166 2013-09-27 18:41 /temp/molpro2012.1.2.block/Molpro/src/boost-install/lib/libboost_system.a

-rw-r--r-- 1 root root  488586 2013-09-27 18:42 /temp/molpro2012.1.2.block/Molpro/src/boost-install/lib/libboost_thread.a

-rw-r--r-- 1 root root 1437226 2013-09-27 18:42 /temp/molpro2012.1.2.block/Molpro/src/boost-install/lib/libboost_wserialization.a


May I learn the correct configure keywords or the suitable parse file to supply in order to get DMRG Block code compile in MOLPRO? Thank you very much for your kind reply.



M.J. Wu




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.molpro.net/pipermail/molpro-user/attachments/20130928/01e221eb/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Type: application/octet-stream
Size: 3027 bytes
Desc: not available
URL: <http://www.molpro.net/pipermail/molpro-user/attachments/20130928/01e221eb/attachment.obj>

More information about the Molpro-user mailing list