[molpro-user] Triplet state calculations

Andy May MayAJ1 at cardiff.ac.uk
Wed Feb 19 08:04:53 GMT 2014


I've built a version as similar as possible (ifort, MKL, same 
version/patchlevel of Molpro) and the input runs for me. I would guess 
it's the compiler version which seems quite old, perhaps the compiler is 
making a mistake whilst optimizing one of the files (I tested with 14.0.2).

If you've access to a more recent ifort try that, or if not try using 
the latest (4.8.2) gfortran. It could well be the case that a new 
version of gfortran outperforms this old version of ifort anyway.

Best wishes,


On 18/02/14 20:55, Alan Chien wrote:
> Update: this error also occurs on a _serial_ version of Molpro which
> we've been running for a while. Similarly, it seg faults after trying to
> access the 2100.2 record. There is an extra line  at the end of the
> Molpro output -  "GLOBAL ERROR fehler on processor  0."
> ~Alan Chien
> On Tue, Feb 18, 2014 at 1:14 PM, Alan Chien <alandc at umich.edu
> <mailto:alandc at umich.edu>> wrote:
>     The output is attached. The program quits after trying to read from
>     a record -> "Reading UHF information from record   2100.2". I know
>     it says UHF, but I'm assuming its just a textual bug since I ran a
>     HF command, which is restricted HF according to the manual. Just to
>     check, I ran it with RHF as the command and the same error occurs.
>     The error log is also attached. You can see it mentions a seg fault.
>     That, plus the fact that the program output has no errors before it
>     crashes, made me suspicious of my installation vs the actual program.
>     As for Bin's suggestions, 1) using the WF card gives the same
>     behavior as the SET card and gives the same error log.
>     2) Running in uccsd(t) goes to completion, but I would like to have
>     restricted orbitals in the end, thus the rmp2. Am i correct in
>     assuming this suggestion was just to test whether the HF code was
>     working correctly?
>     Finally, it may be worth noting that I'm running this on a parallel
>     version of molpro and I'm using 2 processors for this h2o test. Just
>     an extra piece of info that may or may not be helpful.
>     Thank you all of your time,
>     Alan Chien
>     On Tue, Feb 18, 2014 at 11:02 AM, binjiang.nju
>     <binjiang.nju at gmail.com <mailto:binjiang.nju at gmail.com>> wrote:
>         __
>         Alan Chien,
>         It seems to me that the problem is in the rmp2 command. Can you
>         change it to a uccsd(t) and see what will happen?
>         In addition, I usually use wf,nelec,symm,spin for calculations,
>         for example, it is wf,10,1,2 for the H2O( 3^A_1) triplet state.
>         Hope this helps.
>         Best, Bin.
>         ------------------------------------------------------------------------
>         Bin Jiang____
>         Department of Chemistry and Chemical Biology
>         University of New Mexico
>         Albuquerque, NM, 87106
>         binjiang.nju at gmail.com <mailto:binjiang.nju at gmail.com>____
>         *From:* Alan Chien <mailto:alandc at umich.edu>
>         *Date:* 2014-02-17 13 <tel:2014-02-17%C2%A013>:40
>         *To:* molpro-user at molpro.net <mailto:molpro-user at molpro.net>
>         *Subject:* [molpro-user] Triplet state calculations
>         Hello all,
>         I'm trying to figure out how to triplet state calculations
>         single point energy calculations.
>         It seems that all i have to do is set spin to 2. But all of my
>         runs quit soon after it enters the rmp2 portion of the calculation.
>         Does anything in my input look wrong to anyone?
>             ***,H2O Geom Opt.
>             geometry={
>             O        0.3055720076 <tel:3055720076>  1.5171722167
>         -0.0002576327
>             H        1.2948983799  1.4743170340      0.0001818921
>             H        0.0162065756  0.5701892449      0.0094546691
>             }
>             basis=VTZ
>             SET,SPIN=2
>             hf
>             rmp2
>         Or does this input work for anyone else? Maybe its my
>         installation that's incorrect?
>         Thanks for any help
>         Alan Chien
> _______________________________________________
> Molpro-user mailing list
> Molpro-user at molpro.net
> http://www.molpro.net/mailman/listinfo/molpro-user

More information about the Molpro-user mailing list