[molpro-user] undefined references in Opteron 64bit parallel build

Reuti reuti at staff.uni-marburg.de
Wed Dec 1 10:15:11 GMT 2004


> I am currently building MolPro on an Opteron 64bit machine running Fedora
> Core 2.  I built the GA libraries using TCGMSG (I had no luck with LAM-MPI),
> making the changes recommended on the mailing list and successfully running
> test.x.  However, when I attempt to compile molpro, I run across a lot of
> errors of the following type (a typical example):
> : undefined reference to `ga_nodeid_'
> /home1/seth/molpro2002.6/lib/libmolpro.a(muwvfc.o)(.text+0xa6dc): In function
> `prici_':

you have three possibilities to compile GA (TCGMSG, TCGMSG-MPI, MPI) but only 
the first two work with Molpro. I remember to get such errors when I tried to 
compile it with MPI. Did you made a "veryclean" before the new compilation? 
There is for 5.2 also a new note from Nick on the build instructions page 
regarding the built of GA and a posting from 14/07/2004 to change the compiler 
flags for Molpro also.

Cheers - Reuti

More information about the Molpro-user mailing list