[molpro-user] Molpro 2002.6 on Altix Itanium 2/Problem with Molcas angular.f

Jacek Klos jakl at tiger.chem.uw.edu.pl
Wed Aug 31 12:05:43 BST 2005

Dear Molpro users,
I am trying to compile Molpro 2002.6 (serial) on SGI Altix Itanium 2 
machine ia64 on Linux OS.
I use efc 9.0 and ecc 9.0 Intel compiler. Compilation runs fine
up to src/Molcas/angular.f  file, when compiler seems
running and stuck at this file. If I cancel compilation and try
to compile the file manually to get the angular.o object it behaves the 
same.The proccess creates angular.o file with 0 bytes size. The memory 
taken by compiler to compile this file gradually 
increases to 1.6GB and still no object is created. If I run make again the 
compilation goes further (we have now angular.o, but zero in size) and the 
rest of files compile but linking fails due to angular.o being empty. I 
dont recall that this file was taking so long to compile in other 
compilations of molpro on other platforms. Do you have any similar experience?

Other strange behavior is when after configure I run gmake, gmake exits
with error: To much separators in src/util/depend on line 143. And indeed, 
after taking look in the file on line 143 and 144 instead of 
libmol.o:./machine.h appears some piece of C code, which should not be in 
this place (like ffer, (maxbuffer);:./machine.h). I correct the file to 
look like on other succesfull compilations on other platforms to read:
then gmake goes further but gets stuck on the src/Molcas/angular.f file as 
described above.
I will appreciate any hint if this is a bug or efc 9.0 is not supported 
yet by Molpro.

Jacek A. Klos
Quantum Chemistry Laboratory     |
Department of Chemistry          |
University of Warsaw             |
Pasteura 1 Street                |
02-093 Warsaw                    |
Poland                           |
(+4822)8220211 ext. 213          |
e-mail: jakl at tiger.chem.uw.edu.pl|

More information about the Molpro-user mailing list