[molpro-user] Molpro 2002.6 on Altix Itanium 2/Problem with Molcas angular.f

Ross Nobes Ross.Nobes at uk.fujitsu.com
Wed Aug 31 12:31:58 BST 2005

Dear Jacek,

The trick with angular.f is to compile with -O1. With the Intel version
8 compiler -O2 was OK (but -O3 was not), but -O2 with the later version
9 compiler includes some of the optimizations previously only in -O3,
and as a result -O2 no longer works for angular.f.

(I reported this problem to Intel on 11 March 2005, and it was escalated
by Intel in April, but since then I have had no news regarding a fix to
the compiler.)

Best wishes,
Ross Nobes

> -----Original Message-----
> From: owner-molpro-user at molpro1.chem.cf.ac.uk [mailto:owner-molpro-
> user at molpro1.chem.cf.ac.uk] On Behalf Of Jacek Klos
> Sent: 31 August 2005 12:06
> To: molpro-user at molpro.net
> Subject: [molpro-user] Molpro 2002.6 on Altix Itanium 2/Problem with
> Molcas angular.f
> Dear Molpro users,
> I am trying to compile Molpro 2002.6 (serial) on SGI Altix Itanium 2
> machine ia64 on Linux OS.
> I use efc 9.0 and ecc 9.0 Intel compiler. Compilation runs fine
> up to src/Molcas/angular.f  file, when compiler seems
> running and stuck at this file. If I cancel compilation and try
> to compile the file manually to get the angular.o object it behaves
> same.The proccess creates angular.o file with 0 bytes size. The memory
> taken by compiler to compile this file gradually
> increases to 1.6GB and still no object is created. If I run make again
> compilation goes further (we have now angular.o, but zero in size) and
> rest of files compile but linking fails due to angular.o being empty.
> dont recall that this file was taking so long to compile in other
> compilations of molpro on other platforms. Do you have any similar
> experience?
> Other strange behavior is when after configure I run gmake, gmake
> with error: To much separators in src/util/depend on line 143. And
> after taking look in the file on line 143 and 144 instead of
> libmol.o:./machine.h appears some piece of C code, which should not be
> this place (like ffer, (maxbuffer);:./machine.h). I correct the file
> look like on other succesfull compilations on other platforms to read:
> libmol.o:./machine.h
> libmol.o:libmol.c
> then gmake goes further but gets stuck on the src/Molcas/angular.f
file as
> described above.
> I will appreciate any hint if this is a bug or efc 9.0 is not
> yet by Molpro.
> Jacek A. Klos
> ---------------------------------
> Quantum Chemistry Laboratory     |
> Department of Chemistry          |
> University of Warsaw             |
> Pasteura 1 Street                |
> 02-093 Warsaw                    |
> Poland                           |
> (+4822)8220211 ext. 213          |
> e-mail: jakl at tiger.chem.uw.edu.pl|
> ---------------------------------

More information about the Molpro-user mailing list