[molpro-user] installation : problem with the linking step

Yannick Carissan Yannick.Carissan at chemie.uni-karlsruhe.de
Tue Oct 18 14:10:52 BST 2005

Dear molpro users,
I have a problem when I compile molpro on one kind of architecture. The 
compilation on another went fine (AMD Opteron(tm) Processor 246 / SuSE Linux 
9.2 (x86-64)).
The machine is a bi-processor Intel(R) Xeon(TM) CPU 3.06GHz computer which 
runs under SuSE Linux 9.1 (i586). I use the Intel compiler version 8.1., the 
Bash version 3.00.16(1)-release and GNU Make 3.80.

When I run ./configure I set the libraries which contain the blas and lapack 
routines to /usr/app/lib/MATHLIB/i786/lib. This directory exists and contains 
the appropriate libraries :

# ls -1 /usr/app/lib/MATHLIB/i786/lib


When I make I obtain the following message :

# make
everything goes fine
make[2]: Leaving directory `/work/yannick/molpro2002.6/src/cosmo'
if [ ! -r ../lib/libmolpro.a ]; then \
  echo "Rebuilding ../lib/libmolpro.a from scratch" ;\
  ar  -q ../lib/libmolpro.a licence.o ; \
  ar  -q ../lib/libmolpro.a [A-Z]*/*.o ; \
  ar  -q ../lib/libmolpro.a [a-h]*/*.o ; \
  ar  -q ../lib/libmolpro.a [i-z]*/*.o ; \
  true ../lib/libmolpro.a ; \
else \
  echo "Updating ../lib/libmolpro.a" ;\
  make ../lib/libmolpro.a ; \
Updating ../lib/libmolpro.a
make[2]: Entering directory `/work/yannick/molpro2002.6/src'
make[2]: `../lib/libmolpro.a' is up to date.
make[2]: Leaving directory `/work/yannick/molpro2002.6/src'
make[1]: Leaving directory `/work/yannick/molpro2002.6/src'
link date: 18 Oct 2005 14:00:55 ; version: 2002.6
Installed patches: absoft_opt1 absoft_quad acml altix_reshape 
amd64_ifc_i8_blas4a ampr blas_mkl_ia32 bug594 cardiff_doc cardiff_driver 
cidps_orthp ciexit cioccsym citation compress config_pathscale configure_xeon 
corlsi darwin_conf defbas_update dft_orbital_hi displace4 doc_module1 
doc_module2 dplace enest_dummy erel_variables fujitsu_conf fujitsu-ssl2 
ga_conflict2 hpux1131 ia64_efc81 ia64root_check ia64_static ifc_bug 
lapack_init lapi_configure largefiles lsint merge_orbdom mkl60 mkl61 modelopt 
molden_orbital_normalization mpputil mxm_fujitsu mxmsu natorb nec_parse 
opteron2 opteron6 opteron_conf opteron_parse2 orbdom_format 
parse_i686_i4_compat parse_ia64 parse_x86_64_i4 patcher_printf pathf90 
pbs_nodelist pname_intsize posinp project_dav prop_qm pseudo_libmol2 
readop_multipole_nps riblcc_inout rpm_key scfocc scfocc2 sse2 sun_forte8 
sx_updates uncompress updui_trap_overflow wrapper_makefile
/work/yannick/molpro2002.6/bin/ftn: line 114: cd: /usr/app/MATHLIB/i786/lib/: 
No such file or directory
lib.f: compiling ... failed:
/usr/local/bin/ifc -pc 64 -auto -autodouble -Vaxlib -c -w -O3 lib.f

Error : Could not open sourcefile lib.f
compilation aborted for lib.f (code 1)
link failed
cat: /work/yannick/molpro2002.6/bin/molpros_2002_6_i4_p4.exe.log: No such file 
or directory
make: *** [bin/molpros_2002_6_i4_p4.exe] Error 1

The directory /usr/app/MATHLIB/i786/lib/ for which the ftn script complains 
does not exist (the directory which exists and which is present in the CONFIG 
file is /usr/app/lib/MATHLIB/i786/lib/). I do not understand where is my 
mistake. I have tried at least three times on the computer starting from 
scratch (I removed the old molpro directory and decompressed the sources 

To me, it looks like the first occurrence of  'lib' in the name of the 
directory and that the possibility to have twice  'lib' in the name of the 
directory was not handled properly.

Can someone help me?

Yannick Carissan

Lehrstuhl für Theoretische Chemie
Institut für Physikalische Chemie
Universität Karlsruhe (TH)
Kaiserstraße 12
D-76128 Karlsruhe, Deutschland
tel: (49) 721 608 7262
fax: (49) 721 608 7225

More information about the Molpro-user mailing list