[molpro-user] RE: installation error for molpro 2002.6

David Glowacki chmdrgl at leeds.ac.uk
Thu Mar 30 17:33:43 BST 2006

Hello Molpro users,


We are trying to run the ./configure script for putting serial molpro on the
master node of our Beowulf cluster (2 intel 32 bit xeon processors per

We have Red Hat Linux 3.2.2-5, and we are using the ifc v 8.0 fortran

Since my previous message, I have installed the mkl libraries from
www.molpro.net/blaslibs in the default directory.

When I run the configure script, I get the following:


$ ./configure -k token.txt -ifc -p4

Machine architecture is unix unix-i4 unix-linux


File size greater than 2GB allowed


Using Intel Fortran compiler (ifc for ia32) version 8


searching for blas libraries...

found blaslib   -L/usr/lib -lblas -Wl,-rpath,/usr/lib

found blaslib   -L/usr/lib -lcblas -lf77blas -latlas -Wl,-rpath,/usr/lib

found blaslib   -L/opt/intel/mkl/lib/32 -lmkl_p4


blaslibold=-L/opt/intel/mkl/lib/32 -lmkl_p4 -Wl,-rpath,/opt/intel/mkl/lib/32

plese select blas library from above list

(default -L/opt/intel/mkl/lib/32 -lmkl_p4 -Wl,-rpath,/opt/intel/mkl/lib/32




searching for mkl lapack library...

found lapacklib -L/opt/intel/mkl/lib/32 -lmkl_lapack


plese select lapack library from above list

(default -L/opt/intel/mkl/lib/32 -lmkl_lapack
-Wl,-rpath,/opt/intel/mkl/lib/32 ):


Object library exists

Enter max number of atoms [ 200]:

Enter max number of valence orbitals [ 300]:

Enter max number of basis functions [2000]:


If you wish to use a system BLAS library, please give the maximum

level (0, 1, 2, 3) of BLAS to be supplied by the system

(default 3):


Installed binaries directory [/usr/local/bin]


Installed auxiliary directory [/usr/local/lib/molpro-Linux-i686-i4-2002.6]


old CONFIG saved as CONFIG.old

parse-i686-pc-linux-gnu-i4.o.gz is your object.

CONFIG file created; please inspect and edit if necessary before proceeding


Now, whether or not I select '0' or '3' for the level of BLAS to be supplied
to the system, I get the following after a gmake:



everything is o.k.


Installed patches: absoft_opt1 absoft_quad acml alaska_ff altix_reshape
amd64_ifc_i8_blas4a ampr blas_mkl_ia32 bug594 cardiff_doc cardiff_driver
cidps_orthp ciexit cioccsym citation compress config_pathscale
configure_xeon coreocc corlsi darwin_conf defbas_update depositpatch
dft_orbital_hi displace4 doc_module1 doc_module2 dplace email enest_dummy
erel_variables fcibig fix956b fix_kraft1 fujitsu_conf fujitsu-ssl2
ga_conflict2 hpux1131 ia64_efc81 ia64root_check ia64_static ifc_bug intel9b
kext_mpp lapack_init lapi_configure largefiles lsint lvec merge_orbdom mkl60
mkl61 mkl721cluster modelopt molden_orbital_normalization mpp_string mpputil
multi_dens mxm_fujitsu mxmsu natorb nec_parse opteron2 opteron6 opteron_conf
opteron_parse2 optg_inactive orbdom_format parse_i686_i4_compat parse_ia64
parse_x86_64_i4 patcher_printf pathf90 pbs_nodelist pgf_c2h4_ksfreq
pname_intsize posinp project_dav prop_qm pseudo_libmol2 readop_multipole_nps
riblcc_inout rpm_key scfocc scfocc2 sse2 sun_forte8 sx_updates
tran3_core_restart uncompress updui_trap_overflow void_dlnu wrapper_makefile
xlf9a xlf_ndi2

molver.f: compiling ... done

linking /home/mjp/chmdrgl/molpro/molpro2002.6/bin/molpros_2002_6_i4_p4.exe

link failed

/opt/intel/compiler80/ia32/bin/ifc -pc 64 -auto -autodouble -Vaxlib
-Wl,-rpath,/opt/intel/mkl/lib/32 -Wl,-rpath,/opt/intel/mkl/lib/32 -w -O3
-Wl,-rpath,/opt/intel/compiler80/ia32/lib -openmp -o
/home/mjp/chmdrgl/molpro/molpro2002.6/bin/molpros_2002_6_i4_p4.exe molver.o
molpro.o -L/home/mjp/chmdrgl/molpro/molpro2002.6/lib -lmolpro -lgks0
-L/opt/intel/mkl/lib/32 -lmkl_lapack -L/opt/intel/mkl/lib/32 -lmkl_p4 -lz

ifc: warning: The Intel Fortran driver is now named ifort.  You can suppress
this message with '-quiet'

/opt/intel/mkl/lib/32/libmkl_lapack.a(mkl32_support.o)(.text+0x3f): In
function `mkl_strcpy__':

: undefined reference to `s_copy'

/opt/intel/mkl/lib/32/libmkl_lapack.a(mkl32_support.o)(.text+0xc5): In
function `mkl_strcat2__':

: undefined reference to `s_cat'

/opt/intel/mkl/lib/32/libmkl_lapack.a(mkl32_support.o)(.text+0xe4): In
function `mkl_c_sqrt__':

: undefined reference to `c_sqrt'

/opt/intel/mkl/lib/32/libmkl_lapack.a(mkl32_support.o)(.text+0x100): In
function `mkl_c_exp__':

: undefined reference to `c_exp'

/opt/intel/mkl/lib/32/libmkl_lapack.a(mkl32_support.o)(.text+0x11f): In
function `mkl_c_abs__':

: undefined reference to `c_abs'

/opt/intel/mkl/lib/32/libmkl_lapack.a(mkl32_support.o)(.text+0x2f0): In
function `mkl_z_sqrt__':

: undefined reference to `z_sqrt'

/opt/intel/mkl/lib/32/libmkl_lapack.a(mkl32_support.o)(.text+0x310): In
function `mkl_z_exp__':

: undefined reference to `z_exp'

/opt/intel/mkl/lib/32/libmkl_lapack.a(mkl32_support.o)(.text+0x32f): In
function `mkl_z_abs__':

: undefined reference to `z_abs'

make: *** [bin/molpros_2002_6_i4_p4.exe] Error 1


cannot understand.  If I just want to use the libraries that molpro comes
with, why do I get the same error?

I have examined the archives and found that problems with the mkl libraries
were reported previously, albeit with version 6.1, whilst I am using the one
available on the molpro site:




however, I have looked at the response in order to verify that my CONFIG
script matches what is suggested in the response to this query, and I am
absolutely stumped as to why this continues to fail- especially why I get
the same error regardless of whether I tell molpro to use its own libraries.


I attached my CONFIG file.


Any suggestions would be very much appreciated, as I am pretty much
completely stumped.


Thanks very much,

dave glowacki


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.molpro.net/pipermail/molpro-user/attachments/20060330/030259f6/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Type: application/octet-stream
Size: 2811 bytes
Desc: not available
URL: <http://www.molpro.net/pipermail/molpro-user/attachments/20060330/030259f6/attachment.obj>

More information about the Molpro-user mailing list