[molpro-user] configure error for molpro 2002.6

David Glowacki chmdrgl at leeds.ac.uk
Thu Mar 30 12:06:08 BST 2006

Hello Molpro users,


We are trying to run the ./configure script for putting serial molpro on the
master node of our Beowulf cluster (2 intel 32 bit xeon processors per

We have Red Hat Linux 3.2.2-5, and we are using the ifc v 8.0 fortran

With the advice given me by Nick Wilson, I can now run the configure script.
Thanks for that.  

However, when I run the configure script, it at no point gives me a prompt
to ask whether I wish to use system blas libraries or not- instead
immediately searching for the system blas libraries, as follows:


$ ./configure -k token.txt -ifc


Building program for processor type=p4

Program may not run on amd64/athlon/p3 systems

You can choose another processor type using the amd64|athlon|p3 options


Machine architecture is unix unix-i4 unix-linux


File size greater than 2GB allowed


Using Intel Fortran compiler (ifc for ia32) version 8


searching for blas libraries...

found blaslib   -L/usr/lib -lblas -Wl,-rpath,/usr/lib

found blaslib   -L/usr/lib -lcblas -lf77blas -latlas -Wl,-rpath,/usr/lib


blaslibold=-L/usr/lib -lcblas -lf77blas -latlas -Wl,-rpath,/usr/lib

plese select blas library from above list

(default -L/usr/lib -lcblas -lf77blas -latlas -Wl,-rpath,/usr/lib ):




searching for atlas lapack library...

found lapacklib -L/usr/lib -llapack -Wl,-rpath,/usr/lib


plese select lapack library from above list

(default -L/usr/lib -llapack -Wl,-rpath,/usr/lib ):


            Object library exists

Enter max number of atoms [ 200]:

Enter max number of valence orbitals [ 300]:

Enter max number of basis functions [2000]:


If you wish to use a system BLAS library, please give the maximum

level (0, 1, 2, 3) of BLAS to be supplied by the system

(default 3):




if I accept the defaults, then I get the following error after lots of
compiling steps when I run the gmake.  I should note that this error is the
same whether or not I choose '0' or '3' for the level of BLAS to be supplied
to the system:


molver.f: compiling ... done

linking /home/mjp/chmdrgl/molpro/molpro2002.6/bin/molpros_2002_6_i4_p4.exe

link failed

/opt/intel/compiler80/ia32/bin/ifc -pc 64 -auto -autodouble -Vaxlib
-Wl,-rpath,/usr/lib -Wl,-rpath,/usr/lib -w -O3
-Wl,-rpath,/opt/intel/compiler80/ia32/lib -o
/home/mjp/chmdrgl/molpro/molpro2002.6/bin/molpros_2002_6_i4_p4.exe molver.o
molpro.o -L/home/mjp/chmdrgl/molpro/molpro2002.6/lib -lmolpro -lgks0
-L/usr/lib -llapack -L/usr/lib -lcblas -lf77blas -latlas -lz

ifc: warning: The Intel Fortran driver is now named ifort.  You can suppress
this message with '-quiet'

/usr/bin/ld: cannot find -lcblas

gmake: *** [bin/molpros_2002_6_i4_p4.exe] Error 1


so it seems like the standard molpro blas libraries cant be identified.  So
I tried 3 different things: 

(1) I went to www.molpro.net/blaslibs in order to download the
mkl_prod-5[1].1-2.tar file, and I unpacked it in the blaslib directory 

(2) I went to the atlas page and unpacked the atlas3.6.0_Linux_P4SSE2.tgz in
the blaslib directory.  

In both cases (1) and (2), i still get the same configure prompt sequence,
and the same gmake error- so it seems like the configure script cant see
these libraries.  

(3) I tried the command 'wget --cut-dirs=1 -nH -np -r
http://www.molpro.net/blaslibs' as instructed by the installation manual,
and I get a message telling me that authorization failed- despite the fact
that I am able to download patches from the molpro site without a problem.


Any advice that anyone would have for circumventing this problem would
(again) be very much appreciated.


Thanks very much,

dave glowacki

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.molpro.net/pipermail/molpro-user/attachments/20060330/0396135d/attachment.html>

More information about the Molpro-user mailing list