[molpro-user] trouble configuring using Intel fortran on amd64 (opteron)

Kelly Higgins higgins at otto.harvard.edu
Sat May 27 06:38:20 BST 2006

Hi Kirk,

Thanks for your quick response on the eve of Memorial Day weekend.  I 
tried a number of options including -ifc and setting IA64ROOT to no 
avail.  In looking through the getmachine script it appears the Intel 
compiler is only set up for 64 bit compilation for the Itanium 
architecture and not the x86_64 architecture.  The compiler for 64 bit 
x86_64's is called using ifort or ifc, not efc as in the case of the 
Itanium, so configure assumes it is the 32 bit compiler and uses a CFLAG 
of -m32, which leads to the error about the incompatible libsvml.a. 
I've been modifying the getmachine script to work with the x86_64 ifc 
compiler but I haven't gotten it to work yet and I'm not sure about all 
of the flags that should be set.

Does anyone have a CONFIG file that works for x86_64's in 64 bit mode 
using Intel 9.0 fortran and 8.1 mkl?  This configuration is listed in 
the 'Supported machines' but I didn't find a CONFIG file on the 
'Benchmarks' page.


Kirk Peterson wrote:
> Hi Kelly,
> did you use the configure option -ifc and set the environment  variable 
> IA64ROOT to point to the efc executable?
> -Kirk
> On May 26, 2006, at 7:11 PM, Kelly Higgins wrote:
>> Hello Everybody,
>> I am having trouble getting configure for Molpro 2002.6 to run on a  
>> new opteron system.  I am running SuSE 10.0 64 bit and have  installed 
>> Intel 64 bit fortran 9.0 along with mkl 8.1 and I get the  following 
>> error when I run configure:
>> ccb93-180:/usr/local/molpro/intel/molpro2002.6 # ./configure
>> getmachine was unable to identify your operating system correctly.
>> Using Intel compiler /opt/intel/fce/9.0/bin/ifc for bootstrap
>> ifc: warning: The Intel Fortran driver is now named ifort.  You can  
>> suppress this message with '-quiet'
>> ld: skipping incompatible /opt/intel/fce/9.0/lib/libsvml.a when  
>> searching for -lsvml
>> ld: cannot find -lsvml
>> ln: accessing `./machine.exe': No such file or directory
>> gmake: *** [machine.exe] Error 1
>> /bin/sh: ../CONFIG_FRONT: No such file or directory
>> gmake: *** [echo] Error 1
>> utilities/getmachine: line 338: utilities/machine.exe: No such file  
>> or directory
>> If you believe the error is not your fault,
>> then email the molpro mailing list at molpro-user at molpro.net,  
>> specifying operating
>> system type and version, compiler type and version and any other
>> information which would be useful. Exiting ...
>> This configuration is supported according to the 'Supported  machines' 
>> page so why is it hanging at this point?
>> Thanks for any help,
>> Kelly Higgins
>> Department of Chemistry and Chemical Biology
>> Harvard University
>> Cambridge, MA 02138
>> USA

More information about the Molpro-user mailing list