[Molpro-user] {SPAM}? {SPAM}? ? The problem occurs in process_options_array

Andy May MayAJ1 at cardiff.ac.uk
Fri Sep 26 10:20:23 BST 2008


This depends upon how Global Arrays was built, basically if configure
finds libtcgmsg-mpi.a in your Global Arrays build,
/usr/prog/global_arrays/ga-4-0-8/lib/LINUX64 in your case, then it
assumes you used MPI to build GA. For pure tcgmsg builds libtcgmsg.a
should be present and libtcgmsg-mpi.a should not. If you untar a fresh
GA tarball and build with:

make TARGET=LINUX64 FC=ifort CC=icc

then only libtcgmsg.a should be present. If not, please check that
environment variables such as USE_MPI are not set anywhere.

Once this has been fixed configure should automatically put in the
correct settings. You probably need to start from scratch as some of the
preprocessor flags will differ. The following is hopefully the most
compact way of achieving what you want:

/configure -batch -mpp -mppbase /usr/prog/global_arrays/ga-4-0-8 -ifort
-icc -blaspath /usr/prog/intel/mkl/9.1.021/lib/em64t -instroot
/usr/prog/molpro/molpro2008.1 -var

Best wishes,


Richard Christie wrote:
> Hello Andy,
> Thank you for the response. Unfortunately this doesn't fix my problem, I 
> still get exactly the same error. Is there any simple "hello world" type 
> test that I can run to further diagnose this problem? 
> In our previous version of Molpro (2006), it didn't seem necessary to run 
> Molpro through a MPI environment if using tcgmsg; has this changed in 
> 2008?
> Richard
>> Richard,
>> In some cases the mpi launcher does not deal correctly with command line
>> arguments. You should be able to fix your build with the following:
>> rm -f src/util/options.o
>> /configure -batch -f noarg
>> make
>> Best wishes,
>> Andy
>> Richard Christie wrote:
>>> Hello,
>>> I'm having difficulties running a new installation (from source) of
>>> 2008.1. Running on a single core/cpu fails quickly and the job hangs when
>>> running on more than one core/cpu. There is no output file produced, and
>>> the error message in standard output is:
>>> ---
>>>  ? Error
>>>  ? unknown option -p
>>>  ? The problem occurs in process_options_array
>>>  GLOBAL ERROR fehler on processor   0
>>> ---
>>> I've come across a somewhat related e-mail at
>>>   http://www.molpro.net/pipermail/molpro-user/2008-August/002587.html
>>> but I don't think this problem is caused by rc files, as I don't use any 
>>> user-specific configurations files. 
>>> I've included my CONFIG file as an attachment; does anyone have any advice
>>> on how to overcome this problem?
>>> Richard 
>>> ------------------------------------------------------------------------
>>> _______________________________________________
>>> Molpro-user mailing list
>>> Molpro-user at molpro.net
>>> http://www.molpro.net/mailman/listinfo/molpro-user

More information about the Molpro-user mailing list