[molpro-user] BAD TERMINATION

Hans-Joachim Werner werner at theochem.uni-stuttgart.de
Mon Aug 17 07:43:47 BST 2015

Dear Dr. Bozkaya,
I don’t know why your jobs crash, but just a few hints:

(i) CASSCF and CASPT2 are not very well parallelized, and so running in parallel mode does not help much in these cases.
Only rs2 has analytical gradients, unfortunately the much faster rs2c not yet.

(ii) CCSD(T) is quite well parallelized, but does not have analytical gradients yet. Therefore the gradient is computed numerically.
Later this year we will release a new Molpro version, which will have analytical CCSD(T) gradients.

(iii) For numerical gradient or hessian calculations the —-mppx option is useful. This runs calculations for different displacements in parallel, for example

molpro —-mppx -n16 input.inp

(iv) If a parallel calculation fails with an error as you have encountered, you should normally see the output file of the process that failed. For instance, if the process number 4 failed there should be a file input.out_004, and you can check in this file if there is an error message.

If such file is not present, you can run the calculation with

molpro --all-outputs -n16 input.inp

This will save the outputs from all processes in separate files input.out, input.out_001, input.out_002 etc.

which can then be checked.

Best regards
Joachim Werner
Prof. Dr. Hans-Joachim Werner
Institut für Theoretische Chemie
Universität Stuttgart
Pfaffenwaldring 55
D-70569 Stuttgart
Tel: +49 711 / 685 64400
Fax: +49 711 / 685 64442
email: werner at theochem.uni-stuttgart.de

> Am 15.08.2015 um 19:06 schrieb Ugur Bozkaya <ugrbzky at gmail.com>:
> Dear molpro users,
> I can run casscf or caspt2 single point energy computations in the parallel mode. However, when I try to run geometry optimization with casscf or caspt2 in the parallel mode I got the following error:
> However, in the serial mode, I can run geometry optimizations. Similarly, for ccsd I can run single point energies in the parallel mode, however for ccsd(t) I got the same error.
> I run all these jobs with a recent binary of molpro (mpp version) and I run them on the linux (Centos 6). Is there any idea what is going wrong in parallel execution?
> Best regards,
> Ugur Bozkaya 
> -- 
> Assoc. Prof. Ugur Bozkaya
> Department of Chemistry,
> Ataturk University,
> 25240 Erzurum, Turkey,
> Tel: +90 442 231 41 14,
> E-mail: ugrbzky at gmail.com, 
> ugur.bozkaya at atauni.edu.tr.
> _______________________________________________
> Molpro-user mailing list
> Molpro-user at molpro.net
> http://www.molpro.net/mailman/listinfo/molpro-user

More information about the Molpro-user mailing list