[molpro-user] Error: !LICENCE! Password missing on licence token

Andy May MayAJ1 at cardiff.ac.uk
Tue Apr 21 09:50:59 BST 2009


Both MOLPRO_KEY and -k option involve the environment in some way. I
suggest installing the token in a file INSTLIB/.token to avoid use of
the environment for the license key.

Best wishes,


Evgeniy Gromov wrote:
> Dear Andy,
> Thanks for your reply. I did the replacement (it is only
> in one place, namely I replaced "...modules=mpp&..." by
> "...modules=mpp%...") but it didn't help. It still gives
> the same error. I did the replacement in the token and
> also exported MOLPRO_KEY variable (is this variable valid?).
> The token should be fine as I can check patches with "patcher".
> So I am stumped why it doesn't work.
> Best regards,
> Evgeniy
> Andy May wrote:
>> Evgeniy,
>> This error is related to the part of the license token after the
>> ampersand. Some MPI implementations fail to deal with the ampersand
>> character correctly. To circumvent this you can either replace the
>> ampersand character with the percent character which is also permitted.
>> Best wishes,
>> Andy
>> Evgeniy Gromov wrote:
>>> Dear Developers and Users of Molpro,
>>> I get the following error message:
>>> Exit code -5 signaled from n080414
>>> Killing remote processes...!LICENCE! Password missing on licence token
>>> !LICENCE! Password missing on licence token
>>> MPI process terminated unexpectedly
>>> when trying to run a parallel build of molpro. I tried to
>>> set up MOLPRO_KEY and tried to put the license token in the molpro
>>> script in the form -k <token> but nothing did help.
>>> Does someone maybe know what kind of password it asks?
>>> Thanks!
>>> Best regards,
>>> Evgeniy

More information about the Molpro-user mailing list